Android P не позволит работать приложениям для старых версий ОС

После того как компания Google сделала доступной раннюю версию ОС Android P для разработчиков, в сети стало появляться все больше и больше сообщений о том, как именно будет выглядеть следующее поколение Android. И принесет это будущее не только хорошее. В коде ОС нашлось упоминание минимально необходимой версии API для того, чтобы приложение могло быть запущено. Это очередной шаг Google к уменьшению количества работающих версий ОС, но как обычно за счет стимулирования перехода пользователей со старых телефонов на новые. Так что пока компания решает свою проблему, в Android P можно будет встретить сообщение о том, что ваше приложение слишком старое, поэтому его надо обновить или обратиться к разработчику. «Слишком старыми» на данный момент являются приложения для API 17, что соответствует Android 4.2 Jelly Bean. Стоит отметить, что ранее в Google внедрили ограничение по API, который может быть использовано новозагруженное в Play Store приложение, так что все более-менее новые приложения должны без проблем работать в Android P, проблемы будут лишь у тех, кто пользуется чем-то действительно старым и не из официального магазина приложений.